Wednesday, April 23, 2008

cname records, oh my....

A while ago I grabbed the domain thinking I'd give this blog its own domain name rather than just be a blogspot prefix. Blogspot has some pretty good instructions on how to send your blog to your domain name, and I figured this would be pretty easy. I did notice that they didn't have instructions for Network Solutions, but I figured it all must be pretty generic.

I am not an expert in cnames and aliases and hosts and all that stuff. Just not enough UI to keep my interest :-) But how hard can it be? Apparently, hard enough.

Armed with the documentation, I went to setup advanced DNS settings for It seems I need a CNAME record that sends it to and then after that works, all I should need to do is a few steps on blogspot.

So I set up to map to in their domain management tool. It warned it would take a while to replicate around... A few days later when hitting still gave an error, I went back and looked.

It was mapped to With the period at the end. I edited it to remove the period, and figured I had made a typo. Looked at it again, the period was back.

And I'll admit it, that was months ago. There are too many other things on my plate to spend time on that. But I tried again last weekend. I noticed the UI was different, maybe that bug was fixed. Nope, still there.

Now it might be a bug, and it might just as easily (or more likely) be user error. But at this rate it will be a while before sees the light of day!


IdoNotes said...

Let me know if you need help, I host quite a few things through ghs mapped domains

Richard Schwartz said...

It's not likely a bug.

The root of the DNS tree is "."

So ".com" is really ".com."

By convention, you can normally omit the trailing dot, but when you do that there are rules for completion that might apply.

In conventional applications, the rules are generally that if the name does not resolve exactly as it was typed, then the suffixes configured in the local machine's DNS search path are appended and additional attempt to resolve the name are made. Thus, if you had a host called "", then from inside IBM you could just say "ping maureen" and your computer would find "" and ping it. But if you entered "ping maureen.", it would not find it.

When configuring DNS entries, the rule is that if there is no trailing dot, it is relative to the parent domain for which you are creating the entry. Since your CNAME needs to point to a host tha tis outside your domain, the trailing dot is required.

John said...
This comment has been removed by the author.
John said...

In the interim you can do what I did for my niece when I bought her a domain name. She uses blogger also. I just redirected the new domain I bought her back to the blogger URL. At the very least it is easier to tell folks to go to then the long drawn out blogger URL.

Maureen said...

So maybe it is set up correctly? right now yields a 404. I figured I should get the same result as typing in But maybe I should suspend my disbelief and see what happens if I just take the next steps... Once I get brave :-)

Nipponderer #1 said...

Hey Maureen.
Try this tutorial: